Инструкция по установке

imgs_start: 

В блоках Январь 7.2 16кл(21124-1411020-31) с МК saf-c509 Как правило пишут прошивки A205DM53, A205DO54 и A205DO57, в блоки с МК ST10 A205DP57. Будьте внимательны при покупке!
Подготовка блока В последнее время по крайней мере у меня зачастилась такая проблема(то ли блоки такие приходят, толи прошивки в них такие льют): не гаснет главное реле, то есть выкл. зажигание и можно сколь угодно долго ждать затухание светодиода... - это первый признак подводного камня, который стрельнет другой бякой, когда будет запаяна инж.плата. Следует сделать следующее: берём инженерную прошивку(ищем в инете на форумах при помощи [url=http://ru.wikipedia.org/wiki/Гугол]Гугл[/url] :) ) Чистим ЕЕПРОМ. Далее добиваемся того чтобы гл реле нормально гасло после положенных нескольких секунд(которые устанавливаются в прошивке.) если не получается, обесточиваем блок(на пару минут), пробуем снова запустить, если всё равно не получилось повторяем сначала.
Порядок установки платы в блок следующий: 0) записываем во flash инженерную прошивку, например j7es (скачать) или можете посмотреть актуальную версию на форуме 1) счищаем лак с контактных площадок канцелярским ножом (1), делать это следует предельно осторожно, т.к. можно случайно перерезать дорожки. Кроме того, следует зачистить контактные площадки для перемычек (2) 2) припаиваем перемычки, согласно рисунку (2) 3) следует очистить от лака следующие контакты МикроКонтроллера: (3) 4) припаиваем шлейф разпологая плату таким образом, как показано на рисунке (7). 6) все места пайки следует покрыт химически нейтральным флюсом или лаком, можно даже прозрачным лаком для ногтей, но не желательно. 7) плату с обеих сторон покрыть лаком из пульверизатора или аэрозольного баллончика.
Как подключить "на столе" Сделаем "хвост для подключения на столе..." там ни чего сложного. Нужны разъёмчики от корпуса компа(те что на проводах висят) и цепляются к материнке, 2 светодиода лучше разных цветов, 2 сопротивления 1 кОм не менее четверти ватта мощности 2 выключателя с фиксацией. Источник питания, стабилизированный на ток нагрузки не менее полутора ампер, Лампочка 10-15Вт, 12в. в общем так - пины: 12,44,63 - +12 постоянные 13 - зажигание(коммутируем на +12в выключателем) 14 - гл реле, внутри блока коммутируется на массу, подключаем так [14] - [катод анод]- сопротивление 1кОм - [+12] 43 - разрешение программирования (коммутируем на +12 выключателем) 51,53 - масса 70 - реле ЭБН, внутри блока коммутируется на массу, подключаем так [70] - [катод анод]- сопротивление 1кОм - [+12] 71 - КЛиния Лампочку ставим в разрез между + источника питания и + косы
Проверяем блок Если не была произведена подготовка, имеем следующее: блок или не запускается, или гл реле включается но не горит ЭБН(при этом блок выходит на диагностику, но Онлайн режим не работает) - не выпаивая платы пробуем считать прошивку. Если КС верна, то производим подготовку не выпаивая платы. Как только поведение ЭБН и г.Реле стало адекватным, пробуем считать серийник или пробуем подключаться "онлайн-программами". Если при отсутствующем ds2401 - oltsn выдаёт нули, а онлайн программы не работают - очистите EEPROM и перезапустите блок.
Источник проблем Это как правило или прошивка или корявость схемотехники самого блока. чаще всего помогает обесточивание на несколько минут(не знаю что там пишется в ОЗУ, но это что то - постоянно мешает нормальному функционированию.) Причём Самое забавное, что как только блок нормально начал работать - вывести его из строя можно только побаловашись с питанием.

Комментарии

на фотографии с чипом на чипе не помечены к каким ножкам припаивать провода. и те два провода, что идут отдельно было-бы неплохо разделить и как-то пометить.

Хотелось бы фото с припаяным даласом, и какой именно далас нужно для этой платы? За ранее благодарен

6я фотка. ds2401,  любой корпус.

На даласе 3 ножки GND DQ NC на схеме показано куда припаивать GND и DQ а NC не нужно?

NC - NoConnet. кароче пустая нога.

на 6-ой фотке ниже контакта р77 написанно 4.7kOm это что надо сделать ?

это в случае если будете ставить DS2401 - нужно будет запаять это сопротивление, в противном случае оно безполезно

Прошу помощи! Проблема описана по ссылке http://www.ecusystems.ru/forum/viewtopic.php?f=12&t=98

отписАлся там же

Подскажите по подключению адаптере

USB K-Line адаптер 

 к контроллеру ЭСУД инженерному

что именно Вас интересует? к какому пину подключается адаптер в блоке ?

Кто подскажет что такое даллас и для чего он нужен?

DS2401 - что то вроде Rom памяти со вшитой в неё номером. Используется для идеинтификации электронных устройств. Используется разработчиками ПО для привязки железки к программе.

Ясненько. Как я понял для атомик тюна не нужен даллас, ровно также, как и комбилоадеру... В своем блоке обнаружил прошивку дм53, перед установкой платы попытался блок подготовить, слил прошивку, почистил епром, залил другую, тоже дм53. Вот и не пойму теперь, глюк с негаснущим управлением главного реле то есть, то нет. Сегодня впаял плату, все работает, блок на связь, на диагностику выходит. Сравнил контрольную сумму прошки, что на компе и той, что в блоке, все сходится. Вопрос мой в чем, после подключения на столе и после диагностики, не всегда гаснет управление главным реле, это нормально? Повторюсь, плату сегодня впаял, все проверил, все работает. На машину блок еще не ставился после модернизации, так как мотор нестандартный, еще недостроен. И еще смутило при подключении блока через программу openolt с запаянной платой статус еку подключен, а возможности онлайн нет.

 Бывает такое с некоторыми блоками. Причину до сих пор не пойму. Если подцепить релюшку, то она отщёлкнет. Возможно что то связано с диагностикой ИМС драйверов или с М.контроллером. В целом новые блоки работают со светодиодами адекватно, а некоторые Б\У не адекватно. Может это зависит от нагрузки на выход микрушки. Если oltsn ошибку не выдаёт и считываются или нули или серийник, то всё нормально. 

Большое спасибо Вам, Александр, за помощь! Думаю будет все хорошо с блоком, запаял все аккуратно и надежно. В ближайшее время буду готов оформить заказ на программное обеспечение Atomic Tune. Мотор строю турбо на ДАДе.

Отлично! пользуйте.. Будут вопросы-пишите.

На фото 2 нарисованы перемычки как я понял, а на фото 3 уже впаяны перемычки или это чтото другое?

Подскажите. Впаял плату. Если заливаю инженерную прошивку, то не включается бензонасос. На обычных прошивках все работает отлично. По инжинерному протоколу на связь выходит, все работает, кроме бензонасоса. В чем может быть причина?

причина в спешке, читаем инструкцию, вот выдержк

Проверяем блок
Если не была произведена подготовка, имеем следующее: блок или не запускается, или гл реле включается но не горит ЭБН(при этом блок выходит на диагностику, но Онлайн режим не работает) - не выпаивая платы пробуем считать прошивку. Если КС верна, то производим подготовку не выпаивая платы. Как только поведение ЭБН и г.Реле стало адекватным, пробуем считать серийник или пробуем подключаться "онлайн-программами".

Попробовал все что описано выше, нечего не помогло. Причем реле бензонасоса срабатывает и сразу отключается и при запуске не работает. Онлайн программы подключаются. В общем, во время всех манипуляций я забыл отключить питание и начал переставлять контакты. После этого блок перестал выходить на связь в режиме программирования, а затем и вовсе перестал работать. Что это, я спалил блок?

смотря что куда воткнули. если переполюсовка или коротышь по питанию, то как повезёт может всё обойтись погоревшим стабилизатором напруги. А может быть и так что он дальше за собой что нибудь унёс. Проверить можно так: подать 12 в на блок и подать 12в на зажигание. Если на выходе стабилизатора будет 5в, то он жив. Но в нём ещё есть 2 блокировки выключения\включения: одна логическая и управляется драйверами, другая управляется процем. можно попробовать прочитать\очистить еепром.

Добрый день. После долгих мучений каким-то чудом удалось запустить блок. Ничего не сгорело все обошлось. После этого на инженерных прошивках стал работать бензонасос, но теперь не входит в онлайн, пишет switch toRam. Не подключается ни ломаный  j5olt, ни  openOlt. Подскажите в чем может быть причина. Спасибо.

1) oltSN что показывает ?

2) чем шъете ?

3) на долго пробовали обесточиватьблок после того как заработал он ?

4) попробуйте просто прочитать прошивку с блока и очистить еепром.

 

1) oltSN пишет что не может прочитать номер

2) шить пробовал ChipLoader, winflashecu, CombiLoader.

3) Обесточивал почти на сутки

4) тоже делал

Я так понимаю проблему нужно искать теперь в моей пайке, возможно отвалилось. Перемычки нужно паять как на втором фото?

зависит от развотки в блоке. Внимательно посмотрите какая разводка в Вашем блоке. я видел 2 варианта трассировки блока, поэтому выложил как паяются перемычки в обоих.

Добрый день. У меня при подготовке к установке платы возникли трудности понимания. В моем блоке, в том месте, где должны ставиться перемычки, разводка печатной платы слегка отличается от показанной на фотографиях в руководстве по установке. Наличие принципиальной схемы облегчило бы эту проблему. Прилагаю фото платы своего блока производства Автэл. Прошу помочь с установкой платы.

Картинка: 

Поторопился писать вопрос. При внимательном рассмотрении фото нашел свой вариант, и, как следствие, ответ на свой вопрос.

подскажите, запаял плату, прозвонил... в итоге на работающей прошивке (j7esa) блок отказывается включать гл.реле и БН. пробовал прошивать инженерные прошивки(i205dm53.bir), чистить EEPROM - тоже самое. на диагностику выходит, openOLT включает онлайн режим, j5olt тоже блок видит, но простоянно возникает ошибка сброса процессора. плату сейчас выпаял - реле стали работать в штатном режиме. не уж то кроме плохой пайки вариантов нет? реально 10 раз проверил все контакты.

Upd

Перепаял все еще раз. Результат тот же. Можно как то еще проверить кроме как прошивок до посинения?

чем шъёте ?

ChipLoader 1.97.7 проблем с ним не было. по питанию из-за многожильного шлейфа (от IDE) могут быть наводки? может быть такое что какая-нибудь микросхема (FLASH или RAM) просто не успевает "сброситься" и проц выдает ошибку инициализации?

теперь будут. Чиплоадерь не шъёт инженерки. на практике из спортивного интереса паял плату на 60 см шлейф. блок сутки работал под управлением j5olt. прошивка может безпорядочно драгать управлябщими ногами. в результате не своевременного переключения на СРАМ может быть ошибка иниц.

Скажи где можно взять эту прошивку .bir?

на сайте auto-bk.ru, или  в базе знаний можно почитать http://www.tkpiuk.ru/node/82

вообе прошивка не обязательно должна быть bir важно наличие настройки- галки "инженорный блок" в комплектации

Собственно впаял инженерную плату.Прозвонил всю свою пайку,тоже все в норме.В комбиЛодыре блок на связь выходит,прошивка считывается(контролька верна),записал j7esa_v0.4.2_ram.bin.Почистил еепром .Спаял хвост для проверки на столе(так как на автомобиле проверить не имею возможности),после отключения питания с 13ой ноги светодиоды сразу гаснут.Но не одной онлайн программой подключится не получается,пробывал j7olt,openOLT.

на сколько я знаю _ram.bin работает с EEPROM и OpenOlt относительно последних версий. она не предназначена для работы с инженерной платой.

куда подпаивать провод от процессора?ждем фото

8я картинка - добавил распиновку места пайки DS и проводов

AD5 и AD6 должны звонится между собой?

нет

Еще на фото изображены 2 способа подсоединения, где к микроконтроллеру подходят 2 провода припаяные к 92 и 77 ножкам МК, и второй вариант где всего лишь один проводок к 92 ножке, это как то связано с тем, что припаивается даллас? Или это зависит от поставляемой инженерной платки?

Так же интересует, что на фото изображен ЭБУ Я 7.2 с МК saf-c509, то есть попадаются ЭБУ с МК ST10? Что если попадётся именно такой блок? Его нельзя будет сделать инженерным? Может я что то не так понимаю?

Если действительно нельзя сделать инженерным ЭБУ с МК saf-c509, то как можно внешне точно определить по номеру или по надписям на блоке, что там стоит не МК ST10?

ой, оговорился, хотел сказать "если действительно нельзя сделать инженерным ЭБУ с ST10...."

Комбиком Лью j7esa_v0.4.2_ram.bin Впаял плату от http://tkpiuk.ru/j7p_man все помыл все как надо сделал под микроскопом уже все просмотрел, проблема в том что комбик чилает ФЛеШ с FFFF тоесть пустату чебы не залил нечего не считывается соответственно на диагноз не выходит что это? Пайка ну все перепроверил уже...

Комбиком Лью j7esa_v0.4.2_ram.bin Впаял плату от http://tkpiuk.ru/j7p_man все помыл все как надо сделал под микроскопом уже все просмотрел, проблема в том что комбик чилает ФЛеШ с FFFF тоесть пустату чебы не залил нечего не считывается соответственно на диагноз не выходит что это? Пайка ну все перепроверил уже...

COM1: >> Открытие порта...
COM1: >> скорость порта - 57600
ECU: >> Starting Communication
LAMBDA:>> COM2 Открытие порта...
ECU: >> Starting Diagnostic Session
LAMBDA:<< Ошибка связи!(1/1)
ECU: >> Sending "Tester Present"
LAMBDA:<< Ошибка связи!(2/2)
ECU: >> Switch to RAM
Ошибка №1
LAMBDA:<< Ошибка связи!(3/3)
....

LAMBDA:<< Ошибка связи!(39/39)
DS2401 ОК
Номер диска неверный
LAMBDA:<< Ошибка связи!(40/40)
...

LAMBDA:<< Ошибка связи!(51/51)
LAMBDA:>> COM2 Закрытие порта..

...

в комбике стояла галочка защита от чтения, щас диагнос выходит свичтурам пишит везде... даллас читает криво как то.

...

вот читает ДС

Картинка: 

Страницы